当前位置:主页 > 通达信公式 >

MACD面积副图指标 源码 通达信 贴图 看背驰管用

时间:2020-08-31    来源:金牛股票公式网 http://www.zxl888.net/   人气:

MACD面积副图指标
MACD面积副图指标

MACD面积副图指标公式如下

{MACD面积}
P:=12;S:=26;M:=9;
DIFF:EMA(C,P) - EMA(C,S);
DEA:EMA(DIFF,M);
MACD值:2*(DIFF-DEA),COLORSTICK,COLORRED;
BV:=SUM(MACD值,0);
BA:=IF(MAX(BV,REF(BV,2))<REF(BV,1) OR MIN(BV,REF(BV,2))>REF(BV,1),1,0);
BC:=BARSLAST(BA)+1;
SMACD:=BV-REF(BV,BC);
VAR3:=IF(MACD值>0,HHV(ABS(MACD值),BC),LLV(MACD值,BC));
VAR4:=(MACD值)/20;{图形比例缩小1/20,可修改}
面积:SMACD,NODRAW;
DRAWNUMBER(REF(VAR4,1)>0 AND VAR4<=0 ,REF(VAR3,1),REF(面积,1)),COLORMAGENTA;
DRAWNUMBER(REF(VAR4,1)<0 AND VAR4>=0 ,REF(VAR3,1),REF(ABS(面积),1)),COLORGREEN;
DRAWNUMBER(ISLASTBAR AND VAR4<0,REF(VAR3,1),ABS(面积)),COLORMAGENTA;
DRAWNUMBER(ISLASTBAR AND VAR4>0,REF(VAR3,1),面积),COLORGREEN;

相关文章

发表评论

验证码: 看不清?点击更换

注:网友评论仅供其表达个人看法,并不代表本站立场。

公众号