当前位置:主页 > 通达信公式 >

如风主图源码介绍

时间:2020-02-15    来源:金牛股票公式网 http://www.zxl888.net/   人气:

如风主图源码:
{---【如风主图】指标-由往事如风QQ:******** 经海量数据分析及精准校验制作---}
日均价:=DMA(CLOSE,VOL/100);
⑤日:EMA(EMA(EMA((日均价+REF(日均价,1))/2,2),2),2),COLORFFFFFF,NODRAW;
⑩日:IF(MA((日均价+REF(日均价,1))/2,9)=DRAWNULL,EMA((日均价+REF(日均价,1))/2,9),MA((日均价+REF(日均价,1))/2,9)),COLOR00FFFF,NODRAW;
20日:EMA(EMA(EMA((日均价+REF(日均价,1))/2,2),2),16),COLORFF00FF,NODRAW;
60日:MA(CLOSE,60),COLOR00FF00,NODRAW;
半年:MA(CLOSE,120),COLORCC9999,NODRAW;
年线:MA(CLOSE,250),COLORFF8040,NODRAW;

{-------------------------如风股价趋势智能判断系统-------------------------}
智能判断线:=(REF((C*3+H+L+O)/6,1)*0.5+REF((C*3+H+L+O)/6,2)+REF((C*3+H+L+O)/6,3)*0.5)/2;
灰兰风险:=IF(C<智能判断线 AND BETWEEN(智能判断线,C,O),1,0);
阴跌区域:=IF(C<智能判断线 AND NOT(REF(C,1)=智能判断线),1,0);
银底初现:=IF(C>=智能判断线 AND BETWEEN(智能判断线,C,O),1,0);
上升区域:=IF(C>=智能判断线 AND REF(C,1)>智能判断线,1,0);
B1:=REF(CLOSE,1);
B2:=REF(CLOSE,2);
B3:=REF(CLOSE,3);
B4:=REF(CLOSE,4);
CMAX:=MAX(MAX(MAX(CLOSE,B1),B2),B3);
CMIN:=MIN(MIN(MIN(CLOSE,B1),B2),B3);

持股:=(CLOSE=CMAX AND (B1>=B2 OR B1>=B3)) OR ((B1=CMAX AND (B2=CMIN OR B3=CMIN)) AND CLOSE>=B2) OR (B2=CMAX AND B3=CMIN AND CLOSE>=B1) OR (B3=CMAX AND CLOSE>=B1 AND CLOSE>=B2);
变盘:=CLOSE=CMAX AND B1=CMIN;
下跌:=(CLOSE=CMIN AND (B1<B2 OR B1<B3)) OR ((B1=CMIN AND (B2=CMAX OR B3=CMAX)) AND CLOSE<B2) OR (B2=CMIN AND B3=CMAX AND CLOSE<B1) OR (B3=CMIN AND CLOSE<B1 AND CLOSE<B2);
买入:=(B1=CMIN AND CLOSE>=B2) OR ((B2=CMIN AND B1<=B3) OR (B3=CMIN AND B1<=B2) AND B2<B4 AND CLOSE>=B1);
抛售:=(B1=CMAX AND CLOSE<B2) OR ((B2=CMAX AND B1>B3) OR (B3=CMAX AND B1>B2) AND B2>=B4 AND CLOSE<B1);

银色上升变盘:=(下跌 AND O>REF(C,1)) OR 银底初现 OR 变盘;
银色下跌变盘:=(B1=CMAX AND CLOSE=CMIN) OR (下跌 AND 抛售);
银色下跌:=B1=CMAX AND CLOSE=CMIN;

STICKLINE(银色上升变盘 OR 银色下跌变盘,IF(银色下跌,B2,B1),C,3.1,0),COLORA0A0A0;
STICKLINE(银色上升变盘 OR 银色下跌变盘,IF(银色下跌,B2,B1),C,1.9,0),COLORC0C0C0;
STICKLINE(银色上升变盘 OR 银色下跌变盘,IF(银色下跌,B2,B1),C,0.6,0),COLORE0E0E0;

粉色上升变盘:=(持股 AND 买入);
粉色下跌变盘:=(持股 AND C<REF(C,1));

STICKLINE(粉色上升变盘 OR 粉色下跌变盘,B1,CLOSE,3.1,0 ),COLORAA55BB;
STICKLINE(粉色上升变盘 OR 粉色下跌变盘,B1,CLOSE,1.9,0 ),COLORCC77DD;
STICKLINE(粉色上升变盘 OR 粉色下跌变盘,B1,CLOSE,0.6,0 ),COLORFF99FF;

STICKLINE(买入,B1,B2,3.1,0),COLOR00FFFF;
STICKLINE(买入,B1,B2,3.1,0),COLOR009999;

STICKLINE(抛售,B1,B2,3.1,0),COLOR006B00;
STICKLINE(抛售,B1,B2,1.9,0),COLOR007D00;
STICKLINE(抛售,B1,B2,0.6,0),COLOR008F00;

原始K线:DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

STICKLINE(持股 OR 买入,O,C,3.10,0),COLORRED;
冲高回落变盘:=(O>C AND 持股 AND C<REF(C,1));
补充:=B2<O AND 冲高回落变盘 AND O>REF(C,1);
STICKLINE(下跌 OR 抛售 OR 补充,O,C,3.10,0),COLORBBFF54;

STICKLINE(CLOSE<O,OPEN,CLOSE,2.45,0),COLORCC6600;
STICKLINE(CLOSE<O,OPEN,CLOSE,1.45,0),COLORDD7700;
STICKLINE(CLOSE<O,OPEN,CLOSE,0.45,0),COLOREE8800;

STICKLINE(持股,IF(O>REF(C,1) AND C<O AND 冲高回落变盘,B1,C),CLOSE,1.9,0 ),COLORCC77DD;
STICKLINE(持股,IF(O>REF(C,1) AND C<O AND 冲高回落变盘,B1,C),CLOSE,0.6,0 ),COLORFF99FF;

STICKLINE(买入,B1,B2,1.9,0),COLOR00BBBB;
STICKLINE(买入,B1,B2,0.6,0),COLOR00DDDD;
STICKLINE(C>O,OPEN,CLOSE,2.45,0),COLOR440088;
STICKLINE(C>O,OPEN,CLOSE,1.45,0),COLOR550099;
STICKLINE(C>O,OPEN,CLOSE,0.45,0),COLOR6600AA;

{--------------------身怀六甲孕育K线,吗BS买卖点预测------------------------}
身怀六甲:=(((((ABS((REF(CLOSE,1) - REF(OPEN,1))) / REF(CLOSE,1)) > 0.04)
AND ((ABS((CLOSE - OPEN)) / CLOSE) < 0.005)) AND (MAX(CLOSE,OPEN) <
MAX(REF(CLOSE,1),REF(OPEN,1)))) AND (MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1))));
DRAWTEXT(身怀六甲 AND ⑤日<REF(⑤日,1),L-L*0.005,1),COLOR0080FF;
VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
周期限制:=PERIOD=0 OR PERIOD=1 OR PERIOD=8;
B点:=DRAWICON(CROSS(VAR2,MA(VAR3,6)) AND 周期限制=0,(LOW - (LOW*0.015)),11);
S点:=DRAWICON(CROSS(MA(VAR3,6),VAR1) AND 周期限制=0,(HIGH+(HIGH*0.005)),8);

{--价量乃为指标之母,亦即先有股价、成交量,始有指标的产生,成反向推算KDJ价--}
N:=9;M1:=3;M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;

K1:=1/3*RSV+REF(K,1)/3*2;
D1:=1/3*K+REF(D,1)/3*2;
JJ:=3*K1-2*D1;

J11:=J;
J昨:=REF(JJ,1);
JX:=IF(J1=-50,J11,IF(J1=-49,J昨,J1));
J拐点价:=CONST(((9/7*JX-2*REF(K1,1)+12/7*REF(D1,1))/100)*(HHV(HIGH,9)-LLV(LOW,9))+LLV(LOW,9));
K高点价:=CONST(((9/7*CONST(HHV(K,BARSSINCE(C)))-2*REF(K1,1)+12/7*REF(D1,1))/100)*(HHV(HIGH,9)-LLV(LOW,9))+LLV(LOW,9));
K低点价:=CONST(((9/7*CONST(LLV(K,BARSSINCE(C)))-2*REF(K1,1)+12/7*REF(D1,1))/100)*(HHV(HIGH,9)-LLV(LOW,9))+LLV(LOW,9));
K中间价:=(K高点价+K低点价)/2;
STICKLINE(CURRBARSCOUNT=1,K高点价,K高点价,110,0),COLORFF8000;
STICKLINE(CURRBARSCOUNT=1,K低点价,K低点价,110,0),COLORFF0080;
STICKLINE(CURRBARSCOUNT=1,K中间价,K中间价,110,0),COLOR4080FF;
STICKLINE(CURRBARSCOUNT=1,J拐点价,J拐点价,110,-1),COLOR00FFFF;

拐点价:=((9/7*JX-2*REF(K1,1)+12/7*REF(D1,1))/100)*(HHV(HIGH,9)-LLV(LOW,9))+LLV(LOW,9),COLORA0A0A0;
{------------【如风主图】黄金量能智能均线判断系统各均线重新补画------------}
DRAWBAND(年线,RGB(0,0,255),年线,RGB(0,0,255));
DRAWBAND(半年,RGB(128,128,192),半年,RGB(128,128,192));
DRAWBAND(60日,RGB(0,255,0),60日,RGB(0,255,0));
DRAWBAND(20日,RGB(255,0,255),20日,RGB(255,0,255));
DRAWBAND(⑩日,RGB(255,255,0),⑩日,RGB(255,255,0));
DRAWBAND(⑤日,RGB(255,255,255),⑤日,RGB(255,255,255));

STICKLINE(持股 OR 买入,O,O,3.10,0),COLORRED;
STICKLINE(持股 OR 买入,C,C,3.10,0),COLORRED;
STICKLINE(下跌 OR 抛售 OR 补充,O,O,3.10,0),COLORBBFF54;
STICKLINE(下跌 OR 抛售 OR 补充,C,C,3.10,0),COLORBBFF54;
STICKLINE(C>O,O,L,0,0),COLOR3232FF;
STICKLINE(C=O,C,O,3.10,0),COLORFFFFFF;
 


 



 

如风主图源码介绍的选股公式下载如下:

此资源已暂停下载,如果有需要联系站长


复制横线区域的选股公式内容, 打开股票软件,导入到股票选股公式器即可。

如风主图源码介绍使用技巧
1. 首先打开股票软件,Ctrl+F弹出公式管理器,在点击新建出现编辑器;
2. 然后把自己的公式复制到编辑器空白处粘贴;
3. 然后把公式的名称和参数根据条件设置好;
4. 然后点击右边的公式检测看检测结果是否通过,若是通过那么公式就没问题,若是没通过就要修改公式;
5. 然后点击确定这个公式就添加在公式管理器里面了,在公式管理器中找用户的就是自己编辑的;
6. 然后点击公式管理器中的用户公式点击确定,打开股票日线就可以看见自己设置的指标了,基本就是这样,自己可以试试看。

【通达信公式】常见问题

1、问:求高手编写个:N个交易日横盘 振幅不超过M% 的选股公式,N、M可

答:展开全部 {N 1 100 5} {M 1 30 5}HHV(H,N)/LLV(L,N)<=M/100;股票公式专家团为你解答,希望能帮到你,祝投资顺利。

2、问:如何将通达信的技术指标引入条件选股

答:导入条件选股的途径:①修改完后的选股指标源码,想做成选股指标,并非放在指标系统之下的【技术指标】分类,一般是放入【条件选股】分类;便于设置预警、自动选股。②还可将选股指标加入交易系统中,但需要注意的是:输出信号必须为英文单词的买入ENTERLONG、卖出EXITLONG信号。在应用时,飞狐软件输入该交易系统指标名称,即可在主图自动显示买卖信号的提示。源码如下:ENTERLONG:CROSS(MA(C,3),MA(C,8));----表示输出多头买入信号。EXITLONG:CROSS(MA(C,8),MA(C,3));----表示输出空头卖出信号。

3、问:通达信阳包阴选股公式?

答:通达信阳包阴选股公式?一般说的阳包阴指的是两个方面,一是k线上最高值大于昨日阴线最高值,一是今日阳线量能大于昨日阳线量值。所以选股公式应该如下:XG:REF(C,1)<REF(O,1) AND H>=REF(H,1) AND C>MAX(REF(C,1),REF(O,1)) AND V>REF(V,1);选出来效果如图

4、问:股票公式 w底公式怎么写?

答:你看清楚一点啊,最大和最小我都给你分清楚了,把最小、最大、缺省都填在相应的框里运行软件后进入操作界面,点击菜单上的“工具”栏,选择里面的“公式管理”,在跳出的对话框中选择“常用”项目,点击“新建”按钮,在跳出的对话框中选择“技术指标”确定,然后将下面的公式的名称、参数、源码拷贝粘贴,最后按“测试公式”后“确定”就完成了。W底公式参数:N: 缺省:10 最小:1 最大:100GATE1: 缺省:25 最小:1 最大:100GATE2: 缺省:55 最小:1 最大:100GATE3: 缺省:20 最小:1 最大:100源码:p1:=peak(3,N,2);p3:=peak(3,N,1);p2:=trough(3,N,2);p4:=trough(3,N,1);t1:=troughbars(3,N,2)-peakbars(3,N,1);t2:=peakbars(3,N,1)-troughbars(3,N,1);b12:=p1-p2;bpt:=max(p3-p2,p3-p4);b24:=abs(p2-p4);min(t1,t2)>20 and abs(t1-t2)/min(t1,t2)*100

5、问:下面的公式可不可改成5分钟周期的选股公式?主要是适合通达信条件

答:把第一句换成下面这句就可以了;DIFF:EMA(C#MIN5,12)-EMA(C#MIN5,27);

6、问:求高手指点,如何将自编通达信选股公式导入软件,求详细教程!

答:菜单--功能--公式系统--公式管理器--条件选股公式的目录下--任选一个目录--导入公式--找到要导入的公式--确认。

7、问:通信达改选股公式。

答:展开全部 动态底部:=EMA(IF(L<= LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),30,1),0),3)*10;CROSS(动态底部>0,0.5);

8、问:通达信简单技术公式改成选股公式,请教高手??

答:通达信指标公式与选股公式最主要的区别是,指标公式可以有多个输出,而选股公式只能有一个输出。要把指标公式改成选股公式最简单的办法是把你不需要的输出语句改成赋值语句就可以了。 VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL); OBV:SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0); MAOBV:MA(OBV,M); RANGE((((OBV-MAOBV)/MAOBV)*100),-0.5,0.5); 例如,上面是OBV指标公式,一共有三个输出,现在要改成选股公式,那么把不需要的两个语句改成赋值语句就可以了,具体是在输出指标名字后加等号就可以了,改后就是如下 VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL); OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0); MAOBV:=MA(OBV,M); RANGE((((OBV-MAOBV)/MAOBV)*100),-0.5,0.5); 选股公式是要建在条件选股公式栏目里的,建好后在条件选股器里就能看到,也就能执行条件选股了。在条件预警里边就可以把选股公式加进预警里了,进行预警使用了。

9、问:请帮助修改通达信主力控盘选股公式,谢谢

答:以下是修改过的,按问题要求做的主力控盘选股公式,用软件实际测试过能达到要求,可以使用:VUR1:=VOL/CAPITAL;VUR2:=1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1); VUR3:=2.5*MAX(VUR1,VUR2); VUR4:=DMA(CLOSE,VUR3); VUR5:=20*(VUR4/REF(VUR4,1)-1)*38;VUR6:=EMA(VUR5,3); VUR7:=EMA(VUR5,3); VUR8:=EMA(VUR7,5); VURS:=EMA(VUR7,8); VUR9:=1.1*(MAX(INDEXH,REF(INDEXC,1))/MIN(INDEXL,REF(INDEXC,1))-1); VURA:=2.5*MAX(VUR1,VUR9); VURB:=DMA(INDEXC,VURA); VURC:=EMA(20*(VURB/REF(VURB,1)-1),1)*38; VURD:=EMA(VURC,2); VURE:=EMA(VURC,2); DX1:=VURE; DX2:=VURS; DX3:=VUR8; DX4:=VUR7;ZMIN:CROSS(VUR7,20);

10、问:请高手帮我编辑个 通达信30分KDj金叉死叉预警公式!非常感谢!

答:没给字符串N1定义参数。在参数定义里面设置下。【最大值、最小值、缺省值】

金牛股票公式网(www.zxl888.net)编辑提示:
【如风主图源码介绍】是适合【通达信公式】的股票公式。股票市场瞬息万变,请结合实际情况进行使用,勿盲目频繁操作,请各位投资者冷静应对股市。特此赠送【巴菲特】投资金句:【你的人生起点并不重要,重要的是你最终抵达了哪里!】。

相关文章

发表评论

验证码: 看不清?点击更换

注:网友评论仅供其表达个人看法,并不代表本站立场。

公众号